تندآموز مفاهيم شبكه‌هاي كامپيوتري

طراح : محمد صادق مهيني فر

چکيده
فصل اول
شبکه کامپیوتری چیست ؟
مدل های شبکه
اجزا ءشبکه
انواع شبکه از لحاظ جغرافیایی
ریخت شناسی شبکه
پروتکل های شبکه
مدل Open System Interconnection OSI
ابزارهای اتصال دهنده
فصل دوم
مفاهيم مربوط به ارسال سيگنال و پهناي باند
كابل شبكه
كارت شبكه
عملكردهاي اساسي كارت شبكه
نصب كارت شبكه
تنظيمات مربوط به ويندوز براي ايجاد شبكه
شبكه هاي بي سيم
مفاهيم و تعاريف
پارامترهاي مؤثر در انتخاب و پياده‌سازي يك سيستم WLAN

چکيده

استفاده از شبکه های کامپیوتری در چندین سال اخیر رشد فراوانی کرده وسازمانها وموسسات اقدام به برپایی شبکه نموده اند . هر شبکه کامپیوتری باید با توجه به شرایط وسیاست های هر سازمان ، طراحی وپیاده سازی گردد. در واقع شبکه های کامپیوتری زیر ساخت های لازم را برای به اشتراک گذاشتن منابع در سازمان فراهم می آورند؛در صورتیکه این زیر ساختها به درستی طراحی نشوند، در زمان استفاده از شبکه مشکلات متفاوتی پیش آمده و باید هزینه های زیادی به منظور نگهداری شبکه وتطبیق آن با خواسته های مورد نظر صرف شود.
در زمان طراحی یک شبکه سوالات متعددی مطرح می شود:
-برای طراحی یک شبکه باید از کجا شروع کرد؟
-چه پارامترهایی را باید در نظر گرفت ؟
-هدف از برپاسازی شبکه چیست ؟
- انتظار کاربران از شبکه چیست ؟
- آیا شبکه موجود ارتقاء می باید ویا یک شبکه از ابتدا طراحی می شود؟
-چه سرویس ها و خدماتی برروی شبکه ارائه خواهد شد؟

بطور کلی قبل از طراحی فیزیکی یک شبکه کامپیوتری ، ابتدا باید خواسته ها شناسایی وتحلیل شوند، مثلا در یک کتابخانه چرا قصد ایجاد یک شبکه را داریم واین شبکه باید چه سرویس ها وخدماتی را ارائه نماید؛ برای تامین سرویس ها وخدمات مورد نظر اکثریت کاربران ، چه اقداماتی باید انجام داد ؛ مسائلی چون پروتکل مورد نظر برای استفاده از شبکه ، سرعت شبکه واز همه مهمتر مسائل امنیتی شبکه ، هریک از اینها باید به دقت مورد بررسی قرار گیرد. سعی شده است پس از ارائه تعاریف اولیه ، مطالبی پیرامون کاربردهای عملی آن نیز ارائه شود تا در تصمیم گیری بهتر یاری کند.
این مطلب در اصل بعنوان یک پروژه کارشناسی ارشد در زمینه آسان سازی مفهومهای شبکه برای دانشجویان در دانشگاه تهران در سال 1382 اجرا شد.

فصل اول

شبکه کامپیوتری چیست ؟
اساسا یک شبکه کامپیوتری شامل دو یا بیش از دو کامپیوتر وابزارهای جانبی مثل چاپگرها، اسکنرها ومانند اینها هستند که بطور مستقیم بمنظور استفاده مشترک از سخت افزار ونرم افزار، منابع اطلاعاتی ابزارهای متصل ایجاده شده است توجه داشته باشید که به تمامی تجهیزات سخت افزاری ونرم افزاری موجود در شبکه منبع1(Source) گویند.
در این تشریک مساعی با توجه به نوع پیکربندی کامپیوتر ، هر کامپیوتر کاربر می تواند در آن واحد منابع خود را اعم از ابزارها وداده ها با کامپیوترهای دیگر همزمان بهره ببرد.
" دلایل استفاده از شبکه را می توان موارد ذیل عنوان کرد2" :
1 - استفاده مشترک از منابع :
استفاده مشترک از یک منبع اطلاعاتی یا امکانات جانبی رایانه ، بدون توجه به محل جغرافیایی هریک از منابع را استفاده از منابع مشترک گویند.
2 - کاهش هزینه :
متمرکز نمودن منابع واستفاده مشترک از آنها وپرهیز از پخش آنها در واحدهای مختلف واستفاده اختصاصی هر کاربر در یک سازمان کاهش هزینه را در پی خواهد داشت .
3 - قابلیت اطمینان :
این ویژگی در شبکه ها بوجود سرویس دهنده های پشتیبان در شبکه اشاره می کند ، یعنی به این معنا که می توان از منابع گوناگون اطلاعاتی وسیستم ها در شبکه نسخه های دوم وپشتیبان تهیه کرد ودر صورت عدم دسترسی به یک از منابع اطلاعاتی در شبکه " بعلت از کارافتادن سیستم " از نسخه های پشتیبان استفاده کرد. پشتیبان از سرویس دهنده ها در شبکه کارآیی،، فعالیت وآمادگی دایمی سیستم را افزایش می دهد.
4 - کاهش زمان :
یکی دیگر از اهداف ایجاد شبکه های رایانه ای ، ایجاد ارتباط قوی بین کاربران از راه دور است ؛ یعنی بدون محدودیت جغرافیایی تبادل اطلاعات وجود داشته باشد. به این ترتیب زمان تبادل اطلاعات و استفاده از منابع خود بخود کاهش می یابد.
5 - قابلیت توسعه :
یک شبکه محلی می تواند بدون تغییر در ساختار سیستم توسعه یابد وتبدیل به یک شبکه بزرگتر شود. در اینجا هزینه توسعه سیستم هزینه امکانات وتجهیزات مورد نیاز برای گسترش شبکه مد نظر است.
6 - ارتباطات:
کاربران می توانند از طریق نوآوریهای موجود مانند پست الکترونیکی ویا دیگر سیستم های اطلاع رسانی پیغام هایشان را مبادله کنند ؛ حتی امکان انتقال فایل نیز وجود دارد".
در طراحی شبکه مواردی که قبل از راه اندازی شبکه باید مد نظر قرار دهید شامل موارد ذیل هستند:
1 - اندازه سازمان
2 - سطح امنیت
3 - نوع فعالیت
4 - سطح مدیریت
5 - مقدار ترافیک
6 - بودجه
مفهوم گره " Node" وایستگاههای کاری " Work Stations "]1] :
" هرگاه شما کامپیوتری را به شبکه اضافه می کنید ، این کامپیوتر به یک ایستگاه کاری یا گره تبدیل می شود.
یک ایستگاه کاری ؛ کامپیوتری است که به شبکه الصاق شده است و در واقع اصطلاح ایستگاه کاری روش دیگری است برای اینکه بگوییم یک کامپیوتر متصل به شبکه است. یک گره چگونگی وارتباط شبکه یا ایستگاه کاری ویا هر نوع ابزار دیگری است که به شبکه متصل است وبطور ساده تر هر چه را که به شبکه متصل والحاق شده است یک گره گویند".
برای شبکه جایگاه وآدرس یک ایستگاه کاری مترادف با هویت گره اش است.

مدل های شبکه[2]:

در یک شبکه ، یک کامپیوتر می تواند هم سرویس دهنده وهم سرویس گیرنده باشد. یک سرویس دهنده (Server) کامپیوتری است که فایل های اشتراکی وهمچنین سیستم عامل شبکه که مدیریت عملیات شبکه را بعهده دارد - را نگهداری می کند.
برای آنکه سرویس گیرنده " Client" بتواند به سرویس دهنده دسترسی پیدا کند ، ابتدا سرویس گیرنده باید اطلاعات مورد نیازش را از سرویس دهنده تقاضا کند. سپس سرویس دهنده اطلاعات در خواست شده را به سرویس گیرنده ارسال خواهد کرد.
سه مدل از شبکه هایی که مورد استفاده قرار می گیرند ، عبارتند از :
1 - شبکه نظیر به نظیر " Peer- to- Peer "
2 - شبکه مبتنی بر سرویس دهنده " Server- Based "
3 - شبکه سرویس دهنده / سرویس گیرنده " Client Server"

مدل شبکه نظیر به نظیر:
در این شبکه ایستگاه ویژه ای جهت نگهداری فایل های اشتراکی وسیستم عامل شبکه وجود ندارد. هر ایستگاه می تواند به منابع سایر ایستگاه ها در شبکه دسترسی پیدا کند. هر ایستگاه خاص می تواند هم بعنوان Server وهم بعنوان Client عمل کند. در این مدل هر کاربر خود مسئولیت مدیریت وارتقاء دادن نرم افزارهای ایستگاه خود را بعهده دارد. از آنجایی که یک ایستگاه مرکزی برای مدیریت عملیات شبکه وجود ندارد ، این مدل برای شبکه ای با کمتر از 10 ایستگاه بکار می رود .

مدل شبکه مبتنی بر سرویس دهنده :
در این مدل شبکه ، یک کامپیوتر بعنوان سرویس دهنده کلیه فایل ها ونرم افزارهای اشتراکی نظیر واژه پرداز ها، کامپایلرها ، بانک های اطلاعاتی وسیستم عامل شبکه را در خود نگهداری می کند. یک کاربر می تواند به سرویس دهنده دسترسی پیدا کرده وفایل های اشتراکی را از روی آن به ایستگاه خود منتقل کند
مدل سرویس دهنده / سرویس گیرنده :
در این مدل یک ایستگاه در خواست انجام کارش را به سرویس دهنده ارائه می دهد وسرویس دهنده پس از اجرای وظیفه محوله ، نتایج حاصل را به ایستگاه در خواست کننده عودت می دهد. در این مدل حجم اطلاعات مبادله شده شبکه ، در مقایسه با مدل مبتنی بر سرویس دهنده کمتر است واین مدل دارای کارایی بالاتری می باشد.

هر شبکه اساسا از سه بخش ذیل تشکیل می شود[3]:
ابزارهایی که به پیکربندی اصلی شبکه متصل می شوند بعنوان مثال : کامپیوتر ها ، چاپگرها، هاب ها " Hubs "
سیم ها ، کابل ها وسایر رسانه هایی که برای اتصال ابزارهای شبکه استفاده می شوند.
سازگار کننده ها" Adaptor"]4] :
که بعنوان اتصال کابل ها به کامپیوتر هستند . اهمیت آنها در این است که بدون وجود آنها شبکه تنها شامل چند کامپیوتر بدون ارتباط موازی است که قادر به سهیم شدن منابع یکدیگر نیستند . عملکرد سازگارکننده در این است که به دریافت وترجمه سیگنال ها ی درون داد از شبکه از جانب یک ایستگاه کاری وترجمه وارسال برون داد به کل شبکه می پردازد.

اجزا ءشبکه :
اجزا اصلی یک شبکه کامپیوتری عبارتند از :
1 - کارت شبکه : " NIC- Network Interface Card]5]" :
برای استفاده از شبکه وبرقراری ارتباط بین کامپیوتر ها از کارت شبکه ای استفاده می شود که در داخل یکی از شیارهای برد اصلی کامپیوتر های شبکه " اعم از سرویس دهنده وگیرنده " بصورت سخت افزاری وبرای کنترل ارسال ودریافت داده نصب می گردد.
2 - رسانه انتقال " Transmission Medium "]6]:
رسانه انتقال کامپیوتر ها را به یکدیگر متصل کرده وموجب برقراری ارتباط بین کامپیوتر های یک شبکه می شود . برخی از متداولترین رسانه های انتقال عبارتند از : کابل زوج سیم بهم تابیده " Twisted- Pair" ، کابل کواکسیال " Coaxial" وکابل فیبر نوری "Fiber- Optic" .
سیستم عامل شبکه " NOS- Network Operating System"]7] :
سیستم عامل شبکه برروی سرویس دهنده اجرا می شود و سرویس های مختلفی مانند: اجازه ورود به سیستم "Login" ، رمز عبور "Password" ، چاپ فایل ها " Printfiles" ، مدیریت شبکه " Net work management " را در اختیار کاربران می گذارد.

انواع شبکه از لحاظ جغرافیایی:
نوع شبکه توسط فاصله بین کامپیوتر های تشکیل دهنده آن شبکه مشخص می شود:

شبکه محلی " LAN= Local Area Network"]8] :
ارتباط واتصال بیش از دو یا چند رایانه در فضای محدود یک سازمان از طریق کابل شبکه وپروتکل بین رایانه ها وبا مدیریت نرم افزاری موسوم به سیستم عامل شبکه را شبکه محلی گویند. کامپیوتر سرویس گیرنده باید از طریق کامپیوتر سرویس دهنده به اطلاعات وامکانات به اشتراک گذاشته دسترسی یابند. همچنین ارسال ودریافت پیام به یکدیگر از طریق رایانه سرویس دهنده انجام می گیرد. از خصوصیات شبکه های محلی می توان به موارد ذیل اشاره کرد:
1 - اساسا در محیط های کوچک کاری قابل اجرا وپیاده سازی می باشند.
2 - از سرعت نسبتا بالایی برخوردارند.
3 - دارای یک ارتباط دایمی بین رایانه ها از طریق کابل شبکه می باشند.
اجزای یک شبکه محلی عبارتند از :
الف - سرویس دهنده
ب - سرویس گیرنده
ج - پروتکل
د- کارت واسطه شبکه
ط - سیستم ارتباط دهنده
شبکه گسترده " WAN = Wide Area Network" ]9]:
اتصال شبکه های محلی از طریق خطوط تلفنی ، کابل های ارتباطی ماهواره ویا دیگر سیستم هایی مخابراتی چون خطوط استیجاری در یک منطقه بزرگتر را شبکه گسترده گویند. در این شبکه کاربران یا رایانه ها از مسافت های دور واز طریق خطوط مخابراتی به یکدیگر متصل می شوند. کاربران هر یک از این شبکه ها می توانند به اطلاعات ومنابع به اشتراک گذاشته شده توسط شبکه های دیگر دسترسی یابند. از این فناوری با نام شبکه های راه دور " Long Haul Network" نیز نام برده می شود. در شبکه گسترده سرعت انتقال داده نسبت به شبکه های محلی خیلی کمتر است. بزرگترین ومهم ترین شبکه گسترده ، شبکه جهانی اینترنت می باشد.

ریخت شناسی شبکه " Net work Topology" ]10]:
توپولوژی شبکه تشریح کننده نحوه اتصال کامپیوتر ها در یک شبکه به یکدیگر است. پارامترهای اصلی در طراحی یک شبکه ، قابل اعتماد بودن ومقرون به صرفه بودن است. انواع متداول توپولوژی ها در شبکه کامپیوتری عبارتند از :
1 - توپولوژی ستاره ای " Star" ]11]:
در این توپولوژی ، کلیه کامپیوتر ها به یک کنترل کننده مرکزی با هاب متصل هستند. هرگاه کامپیوتری بخواهد با کامپیوتر ی دیگری تبادل اطلاعات نماید، کامپیوتر منبع ابتدا باید اطلاعات را به هاب ارسال نماید. سپس از طریق هاب آن اطلاعات به کامپیوتر مقصد منتقل شود. اگر کامپیوتر شماره یک بخواهد اطلاعاتی را به کامپیوتر شماره 3 بفرستد ، باید اطلاعات را ابتدا به هاب ارسال کند، آنگاه هاب آن اطلاعات را به کامپیوتر شماره سه خواهد فرستاد.
نقاط ضعف این توپولوژی آن است که عملیات کل شبکه به هاب وابسته است. این بدان معناست که اگر هاب از کار بیفتد، کل شبکه از کار خواهد افتاد . نقاط قوت توپولوژی ستاره عبارتند از:
* نصب شبکه با این توپولوژی ساده است.
* توسعه شبکه با این توپولوژی به راحتی انجام می شود.
* اگر یکی از خطوط متصل به هاب قطع شود ، فقط یک کامپیوتر از شبکه خارج می شود.

توپولوژی حلقوی " Ring " ]12]:
این توپولوژی توسط شرکت IBM اختراع شد وبهمین دلیل است که این توپولوژی بنام IBM Tokenring " مشهور است.
در این توپولوژی کلیه کامپیوتر ها به گونه ای به یکدیگر متصل هستند که مجموعه آنها یک حلقه را می سازد. کامپیوتر مبدا اطلاعات را به کامپیوتری بعدی در حلقه ارسال نموده وآن کامپیوتر آدرس اطلاعات رابرای خود کپی می کند، آنگاه اطلاعات را به کامپیوتر بعدی در حلقه منتقل خواهد کرد وبهمین ترتیب این روند ادامه پیدا می کند تا اطلاعات به کامپیوتر مبدا برسد. سپس کامپیوتر مبدا این اطلاعات را از روی حلقه حذف می کند.
نقاط ضعف توپولوژی فوق عبارتند از:
*اگر یک کامپیوتر از کار بیفتد ، کل شبکه متوقف می شود.
* به سخت افزار پیچیده نیاز دارد " کارت شبکه آن گران قیمت است ".
* برای اضافه کردن یک ایستگاه به شبکه باید کل شبکه را متوقف کرد.
نقاط قوت توپولوژی فوق عبارتند از :
* نصب شبکه با این توپولوژی ساده است.
* توسعه شبکه با این توپولوژی به راحتی انجام می شود.
* در این توپولوژی از کابل فیبر نوری میتوان استفاده کرد.

توپولوژی اتوبوسی " BUS"]13]:
در یک شبکه خطی چندین کامپیوتر به یک کابل بنام اتوبوسی متصل می شوند. در این توپولوژی ، رسانه انتقال بین کلیه کامپیوتر ها مشترک است. یکی از مشهورترین قوانین نظارت بر خطوط ارتباطی در شبکه های محلی اترنت است. توپولوژی اتوبوس از متداوالترین توپولوژی هایی است که در شبکه محلی مورد استفاده قرار می گیرد. سادگی ، کم هزینه بودن وتوسعه آسان این شبکه ، از نقاط قوت توپولوژی اتوبوسی می باشد. نقطه ضعف عمده این شبکه آن است که اگر کابل اصلی که بعنوان پل ارتباطی بین کامپیوتر های شبکه می باشد قطع شود، کل شبکه از کار خواهد افتاد.

توپولوژی توری " Mesh"]14] :
در این توپولوژی هر کامپیوتری مستقیما به کلیه کامپیوترهای شبکه متصل می شود. مزیت این توپولوژی آن است که هر کامپیوتر با سایر کامپیوتر ها ارتباطی مجزا دارد. بنابراین ، این توپولوژی دارای بالاترین درجه امنیت واطمینان می باشد. اگر یک کابل ارتباطی در این توپولوژی قطع شود ، شبکه همچنان فعال باقی می ماند.
از نقاط ضعف اساسی این توپولوژی آن است که از تعداد زیادی خطوط ارتباطی استفاده می کند، مخصوصا زمانیکه تعداد ایستگاه ها افزایش یابند. به همین جهت این توپولوژی از نظر اقتصادی مقرون به صرفه نیست. برای مثال ، در یک شبکه با صد ایستگاه کاری ، ایستگاه شماره یک نیازمند به نود ونه می باشد. تعداد کابل های مورد نیاز در این توپولوژی با رابطه N(N-1)/2
محاسبه می شود که در آن N تعداد ایستگاه های شبکه می باشد.

توپولوژی درختی " Tree" ]15] :
این توپولوژی از یک یا چند هاب فعال یا تکرار کننده برای اتصال ایستگاه ها به یکدیگر استفاده می کند. هاب مهمترین عنصر شبکه مبتنی بر توپولوژی در ختی است : زیرا کلیه ایستگاه ها را به یکدیگر متصل می کند. وظیفه هاب دریافت اطلاعات از یک ایستگاه و تکرار وتقویت آن اطلاعات وسپس ارسال آنها به ایستگاه دیگر می باشد.

توپولوژی ترکیبی " Hybrid"
این توپولوژی ترکیبی است از چند شبکه با توپولوژی متفاوت که توسط یک کابل اصلی بنام استخوان بندی " Back bone" به یکدیگر مرتبط شده اند . هر شبکه توسط یک پل ارتباطی " Bridg" به کابل استخوان بندی متصل می شود.
پروتکل[16] :
برای برقراری ارتباط بین رایانه ها ی سرویس گیرنده و سرویس دهنده قوانین کامپیوتری برای انتقال ودریافت داده مشخص شده اند که به قرارداد یا پروتکل موسومند. این قرارداد ها وقوانین بصورت نرم افزاری در سیستم برای ایجاد ارتباط ایفای نقش می کنند. پروتکل با قرارداد ، در واقع زبان مشترک کامپیوتری است که برای درک وفهم رایانه بهنگام در خواست وجواب متقابل استفاده می شود. پروتکل تعیین کننده مشخصه های شبکه ، روش دسترسی وانواع فیزیکی توپولوژی ها ، سرعت انتقال داده ها وانواع کابل کشی است .

پروتکل های شبکه :
ما در این دستنامه تنها دو تا از مهمترین پروتکل های شبکه را معرفی می کنیم:
" پروتکل کنترل انتقال / پروتکل اینترنت
"l/ Inernet Protocol Tcp / ip= Transmission Control Protoc"
پروتکل فوق شامل چهار سطح است که عبارتند از :
الف - سطح لایه کاربرد " Application "
ب - سطح انتقال " Transporter"
ج - سطح اینترنت " Internet"
د - سطح شبکه " Net work"]17]:
" از مهمترین ومشهورترین پروتکل های مورد استفاده در شبکه اینترنت است این بسته نرم افزاری به اشکال مختلف برای کامپیوتر ها وبرنامه ها ی مختلف ارائه می گردد. Tcp/ip از مهمترین پروتکل های ارتباطی شبکه در جهان تلقی می شود ونه تنها برروی اینترنت وشبکه های گسترده گوناگون کاربرد دارد، بلکه در شبکه های محلی مختلف نیز مورد استفاده قرار می گیردو در واقع این پروتکل زبان مشترک بین کامپیوتر ها به هنگام ارسال و دریافت اطلاعات یا داده می باشد. این پروتکل به دلیل سادگی مفاهیمی که در خود دارد اصطلاحا به سیستم باز مشهور است ، برروی هر کامپیوتر وابر رایانه قابل طراحی وپیاده سازی است. از فاکتورهای مهم که این پروتکل بعنوان یک پروتکل ارتباطی جهانی مطرح می گردد، به موارد زیر می توان اشاره کرد:
1 - این پروتکل در چار چوب UNIX Operating System ساخته شده وتوسط اینترنت بکار گرفته می شود.
2 - برروی هر کامپیوتر قابل پیاده سازی می باشد.
3 - بصورت حرفه ای در شبکه های محلی وگسترده مورد استفاده قرار می گیرد.
4 - پشتیبانی از مجموعه برنامه ها وپروتکل های استاندارد دیگر چون پروتکل انتقال فایل " FTP " وپروتکل دو سویه " Point to point Protcol = PPP " .
بنیاد واساس پروتکل Tcp/ip آن است که برای دریافت و ارسال داده ها یا پیام پروتکل مذکور ؛ پیام ها وداده ها را به بسته های کوچکتر وقابل حمل تر تبدیل می کند ، سپس این بسته ها به مقصد انتقال داده می شود ودر نهایت پیوند این بسته ها به یکدیگر که شکل اولیه پیام ها وداده ها را بخود می گیرد ، صورت می گیرد.
یکی دیگر از ویژگی های مهم این پروتکل قابلیت اطمینان آن در انتقال پیام هاست یعنی این قابلیت که به بررسی وبازبینی بسته ها ومحاسبه بسته های دریافت شده دارد. در ضمن این پروتکل فقط برای استفاده در شبکه اینترنت نمی باشد. بسیاری از سازمان وشرکت ها برای ساخت وزیر بنای شبکه خصوصی خود که از اینترنت جدا می باشد نیز در این پروتکل استفاده می کنند. [18]
- پروتکل سیستم ورودی وخروجی پایه شبکه " [19]Net work basic input/ output System= Net Bios" واسطه یا رابطی است که توسط IBM بعنوان استانداردی برای دسترسی به شبکه توسعه یافت . این پروتکل داده ها را از لایه بالاترین دریافت کرده وآنها را به شبکه منتقل می کند. سیستم عاملی که با این پروتکل ارتباط برقرار می کند سیستم عامل شبکه "NOS" نامیده می شود کامپیوتر ها از طریق کارت شبکه خود به شبکه متصل می شوند. کارت شبکه به سیستم عامل ویژه ای برای ارسال اطلاعات نیاز دارد. این سیستم عامل ویژه را Net BIOS می نامند که در حافظه ROM کارت شبکه ذخیره شده است.
Net BIOS همچنین روشی را برای دسترسی به شبکه ها با پروتکل های مختلف مهیا می کند . این پروتکل از سخت افزار شبکه مستقل است . این پروتکل مجموعه ای از فرامین لازم برای در خواست خدمات شبکه ای سطح پایین را برای برنامه های کاربردی فراهم می کند تا جلسات لازم برای انتقال اطلاعات در بین گره ها ی یک شبکه را هدایت کنند.
در حال حاضر وجود " Net BIOS Net BEUI= Net BIOS Enhansed User Interface" امتیازی جدید می دهد که این امتیاز درواقع ایجاد گزینه انتقال استاندارد است و Net BEUI در شبکه های محلی بسیار رایج است. همچنین قابلیت انتقال سریع داده ها را نیز دارد . اما چون یک پروتکل غیر قابل هدایت است به شبکه های محلی محدود شده است.

مدل Open System Interconnection OSI"]20]:
این مدل مبتنی بر قراردادی است که سازمان استانداردهای جهانی ایزو بعنوان مرحله ای از استاندارد سازی قراردادهای لایه های مختلف توسعه دارد . نام این مدل مرجع به این دلیل ا اس آی است چونکه با اتصال سیستم های باز سروکار دارد وسیستم های باز سیستم هایی هستند که برای ارتباط باسیستم های دیگر باز هستند . این مدل هفت لایه دارد که اصولی که منجر به ایجاد این لایه ها
شده اند عبارتند از :
1 - وقتی نیاز به سطوح مختلف از انتزاع است ، لایه ای باید ایجاد شود.
2 - هر لایه باید وظیفه مشخصی داشته باشد.
3 - وظیفه هر لایه باید با در نظر گرفتن قراردادهای استاندارد جهانی انتخاب گردد.
4 - مرزهای لایه باید برای کمینه کردن جریان اطلاعات از طریق رابط ها انتخاب شوند.
اکنون هفت لایه را به نوبت از لایه پایین مورد بحث قرار می دهیم:

1 - لایه فیزیکی :
به انتقال بیتهای خام برروی کانال ارتباطی مربوط می شود. در اینجا مدل طراحی با رابط های مکانیکی ، الکتریکی ، ورسانه انتقال فیزیکی که زیر لایه فیزیکی قراردارند سروکار دارد.
2 - لایه پیوند ها:
مبین نوع فرمت هاست مثلا شروع فریم ، پایان فریم، اندازه فریم وروش انتقال فریم . وظایف این لایه شامل موارد زیر است :
مدیریت فریم ها ، خطایابی وارسال مجدد فریم ها، ایجاد تمایز بین فریم ها داده وکنترل وایجاد هماهنگی بین کامپیوتر ارسال کننده ودریافت کننده داده ها. پروتکل های معروف برای این لایه عبارتند از :
الف - پروتکل SDLC که برای مبادله اطلاعات بین کامپیوتر ها بکار می رود و اطلاعات را به شکل فریم سازماندهی می کند.
ب - پروتکل HDLC که کنترل ارتباط داده ای سطح بالا زیر نظر آن است وهدف از طراحی آن این است که با هر نو ع ایستگاهی کارکند از جمله ایستگاههای اولیه ، ثانویه وترکیبی.
3 - لایه شبکه :
وظیفه این لایه ، مسیر یابی می باشد ، این مسیر یابی عبارتست از : تعیین مسیر متناسب برای انتقال اطلاعات . لایه شبکه آدرس منطقی هر فریم را بررسی می کند . و آن فریم را بر اساس جدول مسیر یابی به مسیر یاب بعدی می فرستد . لایه شبکه مسئولیت ترجمه هر آدرس منطقی به یک آدرس فیزیکی را بر عهده دارد. پس می توان گفت برقراری ارتباط یا قطع آن ، مولتی پلکس کردن از مهمترین وظایف این لایه است. از نمونه بارز خدمات این لایه ، پست الکترونیکی است.
4 - لایه انتقال :
وظیفه ارسال مطمئن یک فریم به مقصد را برعهده دارد. لایه انتقال پس از ارسال یک فریم به مقصد ، منتظر می ماند تا سیگنالی از مقصد مبنی بر دریافت آن فریم دریافت کند. در صورتیکه لایه محل در منبع سیگنال مذکور را از مقصد دریافت نکند. مجددا اقدام به ارسال همان فریم به مقصد خواهد کرد.

5 - لایه اجلاس :
وظیفه برقراری یک ارتباط منطقی بین نرم افزار های دو کامپیوتر ی که به یکدیگر متصل هستند به عهده این لایه است. وقتی که یک ایستگاه بخواهد به یک سرویس دهنده متصل شود ، سرویس دهنده فرایند برقراری ارتباط را بررسی می کند، سپس از ایستگاه ، درخواست نام کاربر، ورمز عبور را خواهد کرد. این فرایند نمونه ای از یک اجلاس می باشد.
6 - لایه نمایش :
این لایه اطلاعات را از لایه کاربرد دریافت نموده ، آنها را به شکل قابل فهم برای کامپیوتر مقصد تبدیل می کند . این لایه برای انجام این فرایند اطلاعات را به کدهای ASCII ویا Unicode تبدیل می کند.
7 - لایه کاربرد :
این لایه امکان دسترسی کاربران به شبکه را با استفاده از نرم افزارهایی چون E-mail- FTP و.... فراهم می سازد.

ابزارهای اتصال دهنده : " Connectivity Devices" :
ابزارهای اتصال به یک شبکه اضافه می گردند تا عملکرد وگستره شبکه وتوانایی های سخت افزاری شبکه را ارتقاء دهند . گستره وسیعی از ابزارهای اتصال در شبکه وجود دارند اما شما احتمالا برای کار خود به ابزارهای ذیل نیازمند خواهید بود:
1 - کنترل کننده ها" Reapeaters " ]21]:
تکرار کننده وسیله ای است که برای اتصال چندین سگمنت یک شبکه محلی بمنظور افزایش وسعت مجاز آن شبکه مورد استفاده قرار می گیرد . هر تکرار کننده از درگاه ورودی " Port " خود داده ها را پذیرفته وبا تقویت آنها ، داده ها را به درگاهی خروجی خود ارسال می کند. یک تکرار کننده در لایه فیزیکی مدل OSI عمل می کند.
هر کابل یا سیم بکار رفته در شبکه که بعنوان محلی برای عبور ومرور سیگنال هاست آستانه ای دارد که در آن آستانه سرعت انتقال سیگنال کاهش می یابد ودر اینجا تکرار کننده بعنوان ابزاری است که این سرعت عبور را در طول رسانه انتقال تقویت می کند.

2 - هاب ها " Hubs"]22] :
ابزاری هستند در شبکه که برای اتصال یک یا بیش از دو ایستگاه کاری به شبکه مورد استفاده قرار می گیرد ویک ابزار معمول برای اتصال ابزارهای شبکه است . هابها معمولا برای اتصال سگمنت های شبکه محلی استفاده می شوند. یک هاب دارای در گاهی های چند گانه است. وقتی یک بسته در یک درگاهی وارد می شود به سایر در گاهی ها کپی می شود تا اینکه تمامی سگمنت های شبکه محلی بسته ها را ببینند. سه نوع هاب رایج وجود دارد:

الف - هاب فعال :
که مانند آمپلی فایر عمل می کند و باعث تقویت مسیر عبور سینگال ها می شود واز تصادم وبرخورد سیگنال ها در مسیر جلوگیری بعمل می آورد . این هاب نسبتا قیمت بالایی دارد.
ب - غیر فعال :
که بر خلاف نوع اول که در مورد تقویت انتقال سیگنال ها فعال است این هاب منفعل است.
ج - آمیخته :
که قادر به ترکیب انواع رسانه ها " کابل کواکسیال نازک ،ضخیم و....." وباعث تعامل درون خطی میان سایر ها بها می شود.

3 - مسیر یاب ها " Routers " ]23]:
در شبکه سازی فرایند انتقال بسته های اطلاعاتی از یک منبع به مقصد عمل مسیر یابی است که تحت عنوان ابزاری تحت عنوان مسیر یاب انجام می شود. مسیر یابی یک شاخصه کلیدی در اینترنت
است زیرا که باعث می شود پیام ها از یک کامپیوتر به کامپیوتر دیگر منتقل شوند. این عملکرد شامل تجزیه وتحلیل مسیر برای یافتن بهترین مسیر است. مسیر یاب ابزاری است که شبکه های محلی را بهم متصل می کند یا به بیان بهتر بیش از دو شبکه را بهم متصل می کند. مسیر یاب بر حسب عملکردش به دونوع زیر تقسیم می شود:
الف - مسیریاب ایستا : که در این نوع ، جدول مسیر یابی توسط مدیر شبکه که تعیین کننده مسیر می باشد بطور دستی مقدار دهی می شود.
ب - مسیر یاب پویا : که در این نوع ، جدول مسیر یابی خودش را، خود تنظیم می کند وبطور اتوماتیک جدول مسیریابی را روز آمد می کند.
4 - دروازه ها "Gateways " ]24]:
دروازه ها در لایه کاربرد مدل ا اس ای عمل می کنند. کاربرد آن تبدیل یک پروتکل به پروتکل دیگر است. هر هنگام که در ساخت شبکه هدف استفاده از خدمات اینترنت است دروازه ها مقوله های مطرح در شبکه سازی خواهند بود.
پل ها " Bridge " ]25]":
یک پل برای اتصال سگمنت های یک شبکه " همگن " به یکدیگر مورد استفاده قرار می گیرد. یک پل در لایه پیوند داده ها " Data link" عمل می کند.
پل ها فریم ها را بر اساس آدرس مقصدشان ارسال می کنند. آنها همچنین می توانند جریان داده ها را کنترل نموده وخطاهایی را که در حین ارسال داده ها رخ می دهد.
عملکرد این پل عبارتست از تجزیه وتحلیل آدرس مقصد یک فریم ورودی واتخاذ تصمیم مناسب برای ارسال آن به ایستگاه مربوطه . پل ها قادر به فیلتر کردن فریم ها می باشند. فیلتر کردن فریم برای حذف فریم های عمومی یا همگانی که غیر ضروری هستند مفید می باشد، پل ها قابل برنامه ریزی هستند ومی توان آنها را به گونه ای برنامه ریزی کرد که فریم های ارسال شده از طرف منابع خاصی را حذف کنند.
با تقسیم یک شبکه بزرگ به چندین سگمنت واستفاده از یک پل برای اتصال آنها به یکدیگر ، توان عملیاتی شبکه افزایش خواهد یافت . اگر یک سگمنت شبکه از کار بیفتد ، سایر سگمنت ها ی متصل به پل می توانند شبکه را فعال نگه دارند ، پل ها موجب افزایش وسعت شبکه محلی می شوند.
سوئیچ ها" Switches " ]26].:
سوئیچ نوع دیگری از ابزارهایی است که برای اتصال چند شبکه محلی به یکدیگر مورد استفاده قرار می گیرد که باعث افزایش توان عملیاتی شبکه می شود. سوئیچ وسیله ای است که دارای درگاه های متعدد است که بسته ها را از یک درگاه می پذیرد، آدرس مقصد را بررسی می کند وسپس بسته ها را به درگاه مورد نظر " که متعلق به ایستگاه میزبان با همان آدرس مقصد می باشد" ارسال می کند. اغلب سوئیچ های شبکه محلی در لایه پیوند داده های مدل ا اس آی عمل می کند.
سوئیچ ها بر اساس کاربردشان به متقارن "Symmetric" ونامتقارن " Asymmetric" تقسیم می شوند.
در نوع متقارن ، عمل سوئیچینگ بین سگمنت هایی که دارای پهنای باند یکسان هستند انجام می دهد یعنی 10mbps به 10mbps و.... سوئیچ خواهد شد. اما در نوع نامتقارن این عملکرد بین سگمنت هایی با پهنای باند متفاوت انجام می شود.

دو نوع سوئیچ وجود دارد که عبارتند از :
1 - سوئیچ Cut - through : این نوع سه یا چهار بایت اول یک بسته را می خواند تا آدرس مقصد آنرا بدست آورد ، آنگاه آن بسته را به سگمنت دارای آدرس مقصد مذکور ارسال می کند این در حالی است که قسمت باقی مانده بسته را از نظر خطایابی مورد بررسی قرار نمی دهد.
2 - سوئیچ Store- and - forward : این نوع ابتدا کل بسته را ذخیره کرده سپس آن را خطایابی می کند ، اگر بسته ای دارای خطا بود آن بسته را حذف می کند ، در غیر اینصورت آن بسته را به مقصد مربوطه ارسال خواهد کرد. این نوع برای شبکه محلی بسیار مناسبتر از نوع اول است زیرا بسته های اطلاعاتی خراب شده را پاکسازی می کند و بهمین دلیل این سوئیچ باعث کاهش بروز عمل تصادف خواهد شد.

فصل دوم

مفاهيم مربوط به ارسال سيگنال و پهناي باند
پهناي باند (Bandwidth) به تفاوت بين بالاترين و پايين‌ترين فركانسهايي كه يك سيستم ارتباطي مي‌تواند ارسال كند گفته مي‌شود. به عبارت ديگر منظور از پهناي باند مقدار اطلاعاتي است كه مي‌تواند در يك مدت زمان معين ارسال شود. براي وسايل ديجيتال، پهناي باند برحسب بيت در ثانيه و يا بايت در ثانيه بيان مي‌شود. براي وسايل آنالوگ، پهناي باند، برحسب سيكل در ثانيه بيان مي‌شود.
دو روش براي ارسال اطلاعات از طريق رسانه‌هاي انتقالي وجود دارد كه عبارتند از: روش ارسال باند پايه (Baseband) و روش ارسال باند پهن (Broadband).]27]
در يك شبكه LAN، كابلي كه كامپيوترها را به هم وصل مي‌كند، فقط مي‌تواند در يك زمان يك سيگنال را از خود عبور دهد، به اين شبكه يك شبكه Baseband مي‌گوئيم. به منظور عملي ساختن اين روش و امكان استفاده از آن براي همه كامپيوترها، داده‌اي كه توسط هر سيستم انتقال مي‌يابد، به واحدهاي جداگانه‌اي به نام Packet شكسته مي‌شود. در واقع در كابل يك شبكه LAN، توالي Packetهاي توليد شده توسط سيستم‌هاي مختلف را شاهد هستيم كه به سوي مقاصد گوناگوني در حركت‌اند.شكلي كه در ادامه خواهد آمد، اين مفهوم را بهتر نشان مي‌دهد.

2-1عملكرد يك شبكه packet-switching
براي مثال وقتي كامپيوتر شما يك پيام پست الكترونيكي را انتقال مي‌دهد، اين پيام به Packetهاي متعددي شكسته مي‌شود و كامپيوتر هر Packet را جداگانه انتقال مي‌دهد. كامپيوتر ديگري در شبكه كه بخواهد به انتقال داده بپردازد نيز در يك زمان يك Packet را ارسال مي‌كند. وقتي تمام Packetهايي كه بر روي هم يك انتقال خاص را تشكيل مي‌دهند، به مقصد خود مي‌رسند، كامپيوتر دريافت كننده آنها را به شكل پيام الكترونيكي اوليه بر روي هم مي‌چيند. اين روش پايه و اساس شبكه‌هاي Packet-Switching مي‌باشد.
در مقابل روش Baseband، روش Broadband قرار دارد. در روش اخير، در يك زمان و در يك كابل، چندين سيگنال حمل مي‌شوند. از مثالهاي شبكه Broadband كه ما هر روز از آن استفاده مي‌كنيم، شبكه تلويزيون است. در اين حالت فقط يك كابل به منزل كاربران كشيده مي‌شود، اما همان يك كابل، سيگنالهاي مربوط به كانالهاي متعدد تلويزيون را بطور همزمان حمل مي‌نمايد. از روش Broadband به طور روز افزوني در شبكه‌هاي WAN استفاده مي‌شود.
از آنجائيكه در شبكه‌هاي LAN در يك زمان از يك سيگنال پشتيباني مي‌شود، در يك لحظه داده‌ها تنها در يك جهت حركت مي‌كنند. به اين ارتباط half-duplex گفته مي‌شود. در مقابل به سيستم‌هايي كه مي‌توانند بطور همزمان در دو جهت با هم ارتباط برقرار كننده full-duplex گفته مي‌شود. مثالي از اين نوع ارتباط شبكه تلفن مي‌باشد. شبكه‌هاي LAN با داشتن تجهيزاتي خاص بصورت full-duplex عمل كنند.

كابل شبكه
پيش از اينكه در مورد انواع كابل‌ها و پهناي باند مربوط به آنها، به بحث بپردازيم، ذكر اين نكته ضروري است كه نوع كابل انتخابي شما بطور مستقيم به توپولوژي شبكه تان وابسته است. در اين قسمت سعي گرديده توپولوژي مناسب با هر نوع كابل ذكر شود.
كابل شبكه، رسانه اي است كه از طريق آن، اطلاعات از يك دستگاه موجود در شبكه به دستگاه ديگر انتقال مي يابد.انواع مختلفي از كابلها بطور معمول در شبكه هاي LAN استفاده مي شوند. در برخي موارد شبكه تنها از يك نوع كابل استفاده مي كند، اما گاه انواعي از كابلها در شبكه به كار گرفته مي شود. غير از عامل توپولوژي، پروتكل و اندازه شبكه نيز در انتخاب كابل شبكه مؤثرند. آگاهي از ويژگيهاي انواع مختلف كابلها و ارتباط آنها با ديگر جنبه هاي شبكه براي توسعه يك شبكه موفق ضروري است.[28]
امروزه سه گروه از كابل‌ها، در ايجاد شبكه مطرح هستند:

كابلهاي Coaxial زماني بيشترين مصرف را در ميان كابلهاي موجود در شبكه داشت. چند دليل اصلي براي استفاده زياد از اين نوع كابل وجود دارد:[29]
1- قيمت ارزان آن.
2- سبكي و انعطاف‌پذيري.
3- اين نوع كابل به نسبت زيادي در برابر سيگنالهاي مداخله‌گر مقاومت مي نمايد.
4- مسافت بيشتري را بين دستگاههاي موجود در شبكه، نسبت به كابل UTP پشتيباني مي‌نمايد.
در شكل زير ساختار كابل Coaxial مشاهده مي‌شود:[30]

(1) Conducting Core يا هسته مركزي كه معمولاً از يك رشته سيم جامد مسي تشكيل مي‌گردد.
(2) Insulation يا عايق كه معمولاً از جنس PVC يا تفلون است.
(3) Copper Wire Mesh كه از سيم‌هاي بافته شده تشكيل مي‌شود و كار آن جمع‌آوري امواج الكترومغناطيسي است.
(4) Jacket كه جنس آن اغلب از پلاستيك بوده و نگهدارنده خارجي سيم در برابر خطرات فيزيكي است.
كابل Coaxial به دو دسته تقسيم مي‌شود:[31]
1- Thin net: كابلي است بسيار سبك، انعطاف‌پذير و ارزان قيمت، قطر سيم در آن 6 ميليمتر معادل 25/0 اينچ است. مقدار مسيري كه توسط آن پشتيباني مي‌شود 185 متر است.
2- Thick net: اين كابل قطري تقريباً 2 برابر Thin net دارد. كابل مذكور، پوشش محافظي را(علاوه بر محافظ خود) داراست كه از جنس پلاستيك بوده و بخار را از هسته مركزي دور مي‌سازد.
رايج‌ترين نوع اتصال دهنده (connector) مورد استفاده در كابل coaxial، Bayonet-Neill-Concelman (BNC) مي‌باشد. انواع مختلفي از سازگار كننده‌ها برايBNCها وجود دارند شامل:Tconnector , Barrel connector وTerminator.
تصوير زير يك BNC connector را نشان مي دهد:[32]

2-3 يك BNC connector

در شبكه هايي با توپولوژي اتوبوسي از كابلcoaxial استفاده مي‌شود. شكل زير نمونه استفاده از اين نوع كابل در شبكه اتوبوسي است:[33]

2-4 استفاده از كابل coaxial در شبكه اتوبوسي
بايد دانست كه از عبارتهايي مانند "10Base5 " براي توضيح اينكه چه كابلي در ساخت شبكه بكار رفته استفاده مي‌گردد. عبارت مذكور بدان معناست كه از كابل coaxial و از نوع Thicknet استفاده شده، علاوه بر آن روش انتقال در اين شبكه، روش Baseband است و نيز سرعت انتقال 10 مگابيت در ثانيه ((mbps مي‌باشد. همچنين "10Base2" يعني اينكه از كابل Thinnet استفاده شده، روش انتقال Baseband و سرعت انتقال 10 مگابيت در ثانيه است.
در طراحي جديد شبكه معمولاً از كابلهاي Twisted Pair استفاده مي‌گردد. قيمت آن ارزان بوده و از نمونه‌هاي آن مي‌توان به كابل تلفن اشاره كرد. اين نوع كابل كه از چهار جفت سيم بهم تابيده تشكيل مي‌گردد، خود به دو دسته تقسيم مي‌شود:[34]
1-(Unshielded Twisted Pair)UTP: كابل ارزان قيمتي است كه نصب آساني دارد و براي شبكه‌هاي LAN سيم بسيار مناسبي است، همچنين نسبت به نوع دوم كم‌وزن‌تر و انعطاف‌پذيرتر است. مقدار سرعت ديتاي عبوري از آن 4 مگابيت در ثانيه تا 100 مگابيت در ثانيه مي‌باشد. اين كابل مي‌تواند تا مسافت حدوداً 100 متر يا 328 فوت را بدون افت سيگنال انتقال دهد. كابل مذكور نسبت به تداخل امواج الكترومغناطيس (Electrical Magnatic Interference) حساسيت بسيار بالايي دارد و در نتيجه در مكانهاي داراي امواج الكترومغناطيس، امكان استفاده از آن وجود ندارد.
در سيم تلفن كه خود نوعي از اين كابل است از اتصال دهنده RJ11 استفاده مي‌شود، اما در كابل شبكه اتصال دهنده‌اي با شماره RJ45 بكار مي‌رود كه داراي هشت مكان براي هشت رشته سيم است. در شكل زير يك connector RJ45 ديده مي‌شود.(برگرفته از پانويس قبلي)

2-5. connector RJ45

كابل UTP داراي پنج طبقه مختلف است (كه البته امروزه CAT6 و CAT7 هم اضافه شده است):
- CAT1 يا نوع اول كابل UTP براي انتقال صدا بكار مي‌رود، اما CAT2‌تا CAT5 براي انتقال ديتا در شبكه‌هاي كامپيوتري مورد استفاده قرار مي‌گيرند و سرعت انتقال ديتا در آنها به ترتيب عبارتست از: 4 مگابيت در ثانيه، 10مگابيت در ثانيه،‌ 16مگابيت در ثانيه و 100مگابيت در ثانيه.
براي شبكه‌هاي كوچك و خانگي استفاده از كابل CAT3‌توصيه مي‌شود.[35]

2-6 كابل UTP

2- (Shielded Twisted Pair)STP : در اين كابل سيم‌هاي انتقال ديتا مانند UTP‌ هشت سيم و يا چهار جفت دوتايي هستند. بايد دانست كه تفاوت آن با UTP‌ در اين است كه پوسته‌اي به دور آن پيچيده شده كه از اثرگذاري امواج بر روي ديتا جلوگيري مي‌كند. از لحاظ قيمت،‌ اين كابل از UTP گرانتر و از فيبر نوري ارزان‌تر است. مقدار مسافتي كه كابل مذكور بدون افت سيگنال طي مي كند برابر با 500 متر معادل 1640 فوت است.
در شبكه‌هايي با توپولوژي اتوبوسي و حلقه‌اي از دو نوع اخير استفاده مي‌شود. گفته شد كه در اين نوع كابل، 4 جفت سيم بهم تابيده بكار مي‌رود كه از دو جفت آن يكي براي فرستادن اطلاعات و ديگري براي دريافت اطلاعات عمل مي‌كنند.
در شبكه‌هايي با نام اترنت سريع١ (Fast Ethernet) دو نوع كابل به چشم مي‌خورد:
- 100Base TX: يعني شبكه‌اي كه در آن از كابل UTP نوع Cat5 استفاده شده و عملاً دو جفت سيم در انتقال ديتا دخالت دارند (دو جفت ديگر بيكار مي‌مانند)، سرعت در آن 100 مگابيت در ثانيه و روش انتقال Baseband است.
- 100Base T4: تنها تفاوت آن با نوع بالا اين است كه هر چهار جفت سيم در آن بكار گرفته مي‌شوند.
كابل فيبر نوري كاملاً متفاوت از نوع Coaxial و Twisted Pair عمل مي‌كند. به جاي اينكه سيگنال الكتريكي در داخل سيم انتقال يابد، پالسهايي از نور در ميان پلاستيك يا شيشه انتقال مي‌يابد. اين كابل در برابر امواج الكترومغناطيس كاملاً مقاومت مي‌كند و نيز تأثير افت سيگنال بر اثر انتقال در مسافت زياد را بسيار كم در آن مي‌توان ديد. برخي از انواع كابل فيبر نوري مي‌توانند تا 120 كيلومتر انتقال داده انجام دهند. همچنين امكان به تله انداختن اطلاعات در كابل فيبر نوري بسيار كم است. كابل مذكور دو نوع را در بر مي‌گيرد:[36]
1- Single Mode: كه دراين كابل ديتا با كمك ليزر انتقال مي‌يابد و بصورت 8.3/125 نشان داده مي‌شود كه در آن 8.3 ميكرون قطر فيبر نوري و 125 ميكرون مجموع قطر فيبر نوري و محافظ آن مي‌باشد. اين نوع كه خاصيت انعطاف‌پذيري كم و قيمت بالايي دارد براي شبكه‌هاي تلويزيوني و تلفني استفاده مي‌گردد.
2- Multi Mode: كه در آن ديتا بصورت پالس نوري انتقال مي‌يابد و بصورت 62.5/125 نشان داده مي‌شود كه در آن 62.5 ميكرون قطر فيبر نوري و 125 ميكرون مجموع قطر فيبر نوري و محافظ آن مي‌باشد. اين نوع مسافت كوتاهتري را نسبت به Single Mode طي مي‌كند و قابليت انعطاف‌پذيري بيشتري دارد. قيمت آن نيز ارزان‌تر است و در شبكه‌هاي كامپيوتري استفاده مي‌شود. بطوركلي كابل فيبر نوري نسبت به دو نوع Coaxial و Twisted pair قيمت بالايي دارد و نيز نصب آن نياز به افراد ماهري دارد. شبكه‌هاي 100Base FX، شبكه‌هايي هستند كه در آنها از فيبر نوري استفاده مي‌شود، سرعت انتقال در آنها 100 مگابيت در ثانيه بوده و روش انتقال Baseband مي‌باشد. امروز، با پيشرفت تكنولوژي در شبكه‌هاي فيبر نوري مي‌توان به سرعت 1000 مگابيت در ثانيه دست يافت. در شكل صفحه بعد يك كابل فيبر نوري مشاهده مي‌شود.[37]

2-7. فيبر نوري

بطور كلي توصيه‌هايي در مورد نصب كابل شبكه وجود دارد:[38]
- هميشه بيشتر از مقدار مورد نياز كابل تهيه كنيد.
- هر بخشي از شبكه را كه نصب مي‌كنيد، آزمايش نماييد. ممكن است بخشهايي در شبكه وجود داشته باشند كه خارج ساختن آنها پس از مدتي دشوار باشد.
- اگر لازم است بر روي زمين كابل‌كشي نماييد، كابلها را بوسيله حفاظت‌كننده‌هايي بپوشانيد.
- دو سر كابل را نشانه‌گذاري كنيد.

كارت شبكه (Network Interface Adapter)
كارت شبكه يا NIC ، وقتي كه در شيار گسترش كامپيوتر( expansion slot: سوكتي در يك كامپيوتر كه براي نگهداري بوردهاي گسترش و اتصال آنها به باس سيستم (مسير انتقال داده‌ها) طراحي مي‌شود. شيارهاي گسترش روشي براي افزايش يا بهبود ويژگيها و قابليت‌هاي كامپيوتر هستند)
قرار مي‌گيرد، وسيله‌اي است كه بين كامپيوتر و شبكه‌اي كه كامپيوتر جزئي از آن است، اتصال برقرار مي‌نمايد. هر كامپيوتر در شبكه مي‌بايست يك كارت شبكه داشته باشد كه به باس گسترش سيستم(System's Expansion Bus) اتصال مي‌يابد و براي رسانه شبكه (كابل شبكه) به عنوان يك واسطه عمل مي‌كند. در برخي كامپيوترها، كارت شبكه با مادربورد يكي شده است، اما در بيشتر مواقع شكل يك كارت گسترش (Expansion Card) را به خود مي‌گيرد كه يا به ISA سيستم (Industry Standard Architecture: مجموعه مشخصاتي براي طراحي باس‌ها كه امكان مي‌دهد قطعات بصورت كارت به شيارهاي گسترش استاندارد كامپيوترهاي شخصي آي‌بي‌ام و سازگار با آنها افزوده شوند)، و يا به PCI (Peripheral Component Interconnect: مجموعه مشخصاتي كه توسط شركت اينتل ارائه شده و سيستم باس محلي را تعريف مي‌كند كه امكان نصب حداكثر 10 كارت گسترش سازگار با PCI را فراهم مي‌كند) متصل مي‌گردد.[39]
كارت شبكه به همراه نرم‌افزار راه اندازي (device driver) آن، مسئول اكثر كاركردهاي لايه data-link و لايه فيزيكي مي‌باشد. كارت‌هاي شبكه، بسته به نوع كابلي كه پشتيباني مي‌كنند، اتصال دهنده‌هاي (Connectors) خاصي را مي‌طلبند. (كابل شبكه از طريق يك اتصال دهنده به كارت شبكه وصل مي‌شود) برخي كارت‌هاي شبكه بيش از يك نوع اتصال دهنده دارند كه اين شما را قادر مي‌سازد كه آنها را به انواع مختلفي از كابلهاي شبكه اتصال دهيد.

عملكردهاي اساسي كارت شبكه
كارت شبكه عملكردهاي گوناگوني را كه براي دريافت و ارسال داده‌ها در شبكه حياتي هستند، انجام مي‌دهد كه برخي از آنها عبارتند از:[40]
1- Data encapsulation: كارت شبكه و درايور (راه‌انداز) آن، مسئول ايجاد فريم در اطراف داده توليد شده توسط لاية شبكه و آماده‌سازي آن براي انتقال هستند.
2- Signal encoding and decoding: در واقع كارت شبكه طرح كدگذاري لايه فيزيكي را پياده مي‌كند و داده‌هاي دودويي (binary) توليد شده توسط لايه شبكه را به سيگنال‌هاي الكتريكي قابل انتقال بر روي كابل شبكه تبديل مي‌نمايد. همچنين سيگنال‌هاي دريافتي از روي كابل را براي استفاده لايه‌هاي بالاتر به داده‌هاي دودويي تبديل مي‌سازد.
3- Data transmission and reception: كاركرد اساسي كارت شبكه، توليد و انتقال سيگنال‌هاي متناسب در شبكه و دريافت سيگنال‌هاي ورودي است. طبيعت سيگنال‌ها به كابل شبكه و پروتكل لايه datalink بستگي دارد. در يك LAN فرضي، هر كامپيوتر هم بسته‌هاي عبوري در شبكه را دريافت مي‌كند و كارت شبكه آدرس مقصد لايه datalink را بررسي مي‌كند تا ببيند آيا بسته براي كامپيوتر مذكور فرستاده شده يا خير. در صورت مثبت بودن پاسخ، كارت شبكه بسته را براي انجام پردازش توسط لايه بعدي از كامپيوتر عبور مي‌دهد، در غير اينصورت بسته را به دور مي‌افكند.
كارت شبكه قابل نقل و انتقال (Portable Computer Network Adapters)
بسيار احتمال دارد كه در شبكه شما يك كامپيوتر كيفي و قابل حمل وجود داشته باشد. گستره وسيعي از كارت شبكه‌هاي مناسب اين كامپيوترها قابل دستيابي است. نوعي از كارت شبكه كه در كامپيوترهاي كيفي استفاده مي‌شود عبارتست از: كارت [41]PCMCIA يا همان PC Card.
كارت PC در يك شيار[42] و يا در يك جفت شيار موجود در كناره كامپيوتر كيفي جاي مي‌گيرد. كابل شبكه با استفاده از ابزاري به نام "dongle" به كارت PC متصل مي‌شود. كارتهاي PC جز ابزارهاي "Plug-and-Play" هستند، و نيز مي‌توان در حاليكه كامپيوتر روشن و در حال فعاليت است، آنها را نصب يا خارج نمود و پس از نصب آنها نيازي به restart كردن كامپيوتر نيست.

نصب كارت شبكه
براي نصب كارت شبكه، توصيه مي‌شود كه از دستورالعمل‌هاي همراه كارت شبكه خود پيروي كنيد. سعي كنيد كارت شبكه‌اي را خريداري نمائيد كه اين دستورالعمل‌ها را با خود داشته باشد. اگر قصد داريد از كارتي استفاده كنيد كه آن را از كامپيوتر ديگري بيرون كشيده‌ايد و يا دوستتان آن را به شما داده است، ابتدا در دو روي آن كارت شبكه نام سازنده و شماره محصول را بررسي كنيد. حداقل يافتن نام سازنده - درصورت وجود - آسان است. در درجه دوم،‌ به سايت سازنده در وب مراجعه نموده و اطلاعات فني دربارة‌ آن كارت شبكه جستجو كنيد. سعي كنيد شماره محصول، مدل و شماره سريال‌ها را تطبيق دهيد. راهي ديگر نيز براي شناختن سازندة‌ كارت شبكه وجود دارد. بر روي كارت شبكه يك كد شش رقمي است كه از حروف و عدد تشكيل يافته است (مثل OOAOC9).]43]
شماره مذكور به OUI (Organizationally Unique Identifier) معروف است. در صورت وجود OUI شما قادر هستيد سازنده كارت و نيز درايور مناسب را بيابيد. شماره OUI توسط IEEE (Institute for Electrical and Electronical Engineers) تخصيص داده مي‌شود و از طريق پايگاه داده‌هاي آن مي‌توان به جستجوي نام سازندگان پرداخت. (www.ieee.org) شما مي‌بايست به منظور كاركرد صحيح كارت شبكه در كامپيوترتان، يك درايور[44] براي آن داشته باشيد. اگر كارت شبكه‌اي را از يك توليد كننده معروف در دست داريد، اين شانس وجود دارد كه ويندوز درايور آن را در فايلهاي خود داشته باشد. اما در غير اينصورت يا بايد به دريافت درايور از اينترنت اقدام كنيد و يا ديسكت و يا CD-ROM مربوط به كارت شبكه را در اختيار داشته باشيد.
برخي كارت‌هاي شبكه در ديسكت يا CD-ROM خود،‌ يك نصب نرم‌افزاري را پيش‌بيني مي‌كنند. سعي كنيد اين نصب را پيش از رفتن به مراحل بعدي كامل كنيد. بهترين راه براي پاسخگويي به سؤالاتي كه در حين مراحل نصب ممكن است برايتان پيش بيايد، مراجعه به وب سايت سازنده است.[45]
فرايند نصب كارت شبكه شامل مراحل زير است:[46]
- جايدهي فيزيكي كارت در كامپيوتر.
- پيكربندي (Configuring) كارت براي استفاده از منابع سخت‌افزاري مناسب.
- نصب نرم‌افزاري راه‌اندازي (device driver) كارت.
در مراحل نصب و راه‌اندازي شبكه ابتدا مي‌بايست مسير كابل‌كشي كه بطور فيزيكي كامپيوترهاي شما را به يكديگر متصل مي‌كند مشخص شود. يك روش آسان ولي مؤثر در طراحي مسير جايگيري كابل‌ها، اين است كه با در دست داشتن يك دفترچه يادداشت و يك مداد، از يك مكان دلخواه براي كامپيوتر به سمت مكان ديگر حركت كنيد و بدين شكل يك طرح كلي را از كف خانه خود بدست آوريد؛ همينطور كه پيش مي‌رويد هرگونه مانعي را كه مي‌بايست فكري برايش كرد يادداشت كنيد مثل ديوارها، لوله‌ها، لوازم خانه،‌درخت‌ها و غيره.
اگر قصد داريد كابل‌كشي را بر روي زمين و به موازات لبه‌هاي ديوار انجام دهيد، خوب است كابل‌ها را با استفاده از يك سري نگهدارنده‌هاي پلاستيكي به ديوار محكم كنيد. در هنگام نصب كابل در اطراف مجراهاي گرمايي يا تهويه، سيستم‌هاي خلاء مركزي و يا سيستم‌هاي برق، دقت لازم را به عمل آوريد.
پس از طراحي مسير كابل‌ها، به اندازه‌گيري مسير واقعي آنها بر روي زمين بپردازيد. فراموش نكنيد كه اگر قرار است يك كامپيوتر بر روي ميز قرار گيرد لازم است كه فاصله پشت كيس كامپيوتر را تا زمين اندازه‌ بگيريد. همچنين اندازه‌ گوشه‌ها و زواياي ديوارها را بيفزاييد. پس از پايان اين مرحله مجدداً‌ به اندازه‌گيري مسير كابل‌ها بپردازيد و اندازه‌هاي قبلي خود را بررسي و اصلاح نمائيد. آنگاه همة‌ اندازه‌هاي بدست آمده را براي بدست آوردن كل طول كابل مورد نياز، با هم جمع كنيد. اندازه‌اي حدود ده فوت را به كل اندازه‌ كابل مورد نياز بيفزاييد، اين طول اضافي بابت موانعي است كه به آساني قابل اندازه‌گيري نيستند مثل زوايا و گوشه‌ها و يا پله‌ها.[47]
براي ادامه كار شما به كابل Cat5 به همراه اتصال دهنده‌هاي RJ-45 نياز داريد.
به منظور جايدهي فيزيكي كارت شبكه در كامپيوتر، ابتدا كامپيوتر را خاموش كنيد. سپس كيس كامپيوتر را باز نمائيد و به دنبال يك شيار (slot) آزاد بگرديد. در بازار هر دو نوع كارت شبكه ISA و PCI وجود دارند و شما قبل از انتخاب كارت بايد بررسي كنيد كه كامپيوترتان چه نوع شياري را دارا مي‌باشد. كارت‌هاي ISA براي استفاده‌هاي معمولي شبكه كافي هستند اما امروزه اين نوع باس‌ها با PCI جايگزين شده‌اند. در صورتيكه بخواهيد كامپيوتر خود را به شبكه‌هاي پر سرعت (100-Mbps) وصل كنيد، باس PCI را ترجيح دهيد. پس از خارج ساختن پوشش شيار، كارت را درون شيار جاي دهيد و آن را محكم كنيد.
در مرحله دوم،‌ پيكربندي كارت شبكه به منظور استفاده آن از منابع سخت‌افزاري خاص صورت مي‌گيرد. مثالهايي از اين منابع سخت‌افزاري عبارتند از:[48]
- Interrupt requests (IRQS): يعني خطوط سخت‌افزاري كه وسايل جانبي از آنها براي فرستادن سيگنال‌ها به پردازشگر و درخواست توجه آن، استفاده مي‌كنند.
- Input/Output (I/O) port addresses: اين مكان‌ها در حافظه براي استفاده وسايل خاص و به منظور تبادل اطلاعات با ديگر بخشهاي كامپيوتر، تخصيص داده مي‌شوند.
- Memory addresses: اين مكانها از حافظه توسط وسايل خاص و به منظور نصب BIOS با هدف خاصي استفاده مي‌شوند.
- Direct memory access (DMA) channels: يعني مسيرهاي سيستمي كه وسايل از آنها براي تبادل اطلاعات با حافظه سيستم استفاده مي‌كنند.
كارت‌هاي شبكه معمولاً از آدرسهاي حافظه يا DMA استفاده نمي‌كنند، اما هر كارت شبكه به يك IRQ و نيز آدرس I/O پورت براي برقراري ارتباط با كامپيوتر نياز دارد. وقتي شما كامپيوتر و كارت شبكه‌اي را داشته باشيد كه هر دو از استاندارد "Plug and Play" (يعني توانايي يك سيستم كامپيوتري براي پيكربندي خودكار وسيله‌اي كه به آن افزوده مي‌شود) پشتيباني كنند، فرايند پيكربندي (مرحله دوم) به طور خودكار انجام مي‌گيرد. كامپيوتر كارت شبكه را تشخيص داده،‌آن را شناسايي مي‌كند، همچنين منابع آزاد را مكان‌يابي كرده و به پيكربندي كارت شبكه براي استفاده از آنها اقدام مي‌كند. عدم وجود مكان "Plug and Play" به معني آنست كه شما بايد كارت شبكه را براي استفاده از IRQ خاص و پورت I/O پيكربندي نمائيد و سپس اين تنظيمات را با تنظيمات درايور كارت شبكه تطبيق دهيد. البته اين حالت بيشتر در كارت‌ شبكه‌هاي قديمي اتفاق مي‌افتد. تقريباً از ويندوز 95 به بعد، ابزارهايي به منظور تشخيص برخوردهاي سخت‌افزاري در اختيار كاربران قرار گرفته است. "Device Manager" تنظيمات سخت‌افزاري همه اجزاء را در كامپيوتر فهرست مي‌كند، و هنگاميكه در مورد كارت شبكه‌اي كه به تازگي نصب شده، يك برخورد سخت‌افزاري پيش مي‌آيد، اين ابزار شما را آگاه مي‌سازد. شما مي‌توانيد از "Device Manager" براي تشخيص اينكه كارت شبكه با چه وسيله‌اي برخورد دارد و چه منبعي احتياج به تنظيم دارد، استفاده نمائيد.
مرحله سوم شامل نصب درايو‌هاي كارت شبكه است. نرم‌افزار راه‌اندازي (device driver) بخشي از كارت شبكه است كه كامپيوتر را قادر مي‌سازد با كارت شبكه ارتباط برقرار كرده و كاركردهاي مورد نياز را اجرا كند. در حقيقت تمامي كارت‌هاي شبكه براي پشتيباني از سيستم‌هاي عامل مطرح،‌ با يك نرم‌افزار راه‌اندازي عرضه مي‌شوند، اما در بسياري از موارد، شما حتي به اين نرم‌افزار احتياج پيدا نخواهيد كرد زيرا سيستم‌هاي عاملي مثل ويندوز، مجموعه‌اي از درايوها را براي مدلهاي كارت شبكه پراستفاده و رايج شامل مي‌گردند. با وجود امكان "Plug and Play"، علاوه بر تنظيم پيكربندي منابع سخت‌افزاري كارت شبكه، درايور مناسب نيز نصب مي‌شود. شما مي‌توانيد جديدترين درايورهاي مربوط به كارت شبكه را از سايت سازندة آن بدست آوريد. البته نصب درايور جديد تنها در صورت بروز مشكل ضرورت پيدا مي‌كند.

تنظيمات مربوط به ويندوز براي ايجاد شبكه[49]
حال وقت آن است كه در سيستم عامل خود تنظيماتي را انجام دهيد تا كامپيوتر شما بتواند جستجو براي كامپيوترهاي ديگر و گفتگو با آنها را آغاز كند.
نحوه پيكربندي تنظيمات مربوط به ويندوز در كامپيوتر شما، توسط اين مسأله تعيين مي‌شود كه آيا در شبكه شما Internet sharing وجود دارد يا خير. در ادامه بر حسب اين مسأله دستورالعمل‌هاي لازم آورده مي‌شود:
Non-Internet Sharing Windows Settings
در مورد هر كامپيوتر مراحل زير را طي كنيد:
1. بر روي آيكن Network Neighborhood بر روي desktop راست كليك كنيد.
2. Properties را انتخاب كنيد.
3. بر روي Access Control tab كليك كرده و Share level access را انتخاب كنيد.
4. Identification tab را انتخاب كنيد.
در اينجا مي‌توانيد نامي را براي كامپيوتر خود انتخاب كنيد.
5. Configuration tab را انتخاب كنيد. از Primary Network Logon، Client for Microsoft Networks را انتخاب كنيد.
6. سپس يك آدرس IP را به كامپيوتر اختصاص دهيد، مثلاً 192.168.O.X. X در هر كامپيوتر منحصر به فرد است و عددي بين 1 تا 254 مي‌باشد. در اين قسمت عدد Subnet mask را، 255.255.255.0 بنويسيد.
Internet Sharing Windows Setting
در مورد هر كامپيوتر مراحل زير را اجرا كنيد:
- در Control Panel، بر روي آيكن Add/Remove Program دو بار كليك كنيد. بر روي Windows setup tab كليك كنيد.
- پس از گذشت چند لحظه از ليست اجزاء، Internet tools را انتخاب كنيد.
- سپس Internet Connection Sharing را انتخاب كنيد.
- در اينجا CD مربوط به ويندوز مورد نياز است. آنگاه Internet Connection Sharing Wizard اجرا مي‌گردد كه پس از پايان آن، كامپيوتر را Restart نماييد.
- مي‌توانيد از فلاپي ديسكي كه در طي مراحل Wizard ايجاد مي‌كنيد، در مورد كامپيوترهاي ديگر شبكه استفاده كنيد (در منوي Run در هر يك از آنها و پس از گذاشتن فلاپي در كامپيوتر اينگونه تايپ كنيد: a:\icsclset.exe و سپس Enter را فشار دهيد)
لازم به ذكر است در صورتيكه بخواهيد شبكه خود را از طريق يك Proxy Server به اينترنت متصل كنيد مي‌بايست آن را خريداري كرده و تنظيمات مربوطه را انجام دهيد. فراهم كننده خدمات اينترنت (ISP) شما بايد در مورد استفاده از dynamic IP و يا static IP شما را آگاه سازد. در صورت استفاده از static IP، ISP بايد در اختصاص IP به شما كمك كند.

شبكه هاي بي سيم WirelessNetworking

مفاهيم و تعاريف

وقتي از شبكه اطلاع‌رساني سخن به ميان مي‌آيد، اغلب كابل شبكه به عنوان وسيله انتقال داده در نظر گرفته مي‌شود. در حاليكه چندين سال است كه استفاده از شبكه سازي بي‌سيم در دنيا آغازگرديده است. تا همين اواخر يك LAN بي‌سيم با سرعت انتقال پايين و خدمات غيرقابل اعتماد و مترادف بود، اما هم اكنون تكنولوژي‌هاي LAN بي‌سيم خدمات قابل قبولي را با سرعتي كه حداقل براي كاربران معمولي شبكه كابلي پذيرفته شده مي‌باشد، فراهم مي‌كنند.
WLANها (يا LANهاي بي‌سيم) از امواج الكترومغناطيسي (راديويي يا مادون قرمز) براي انتقال اطلاعات از يك نقطه به نقطه ديگر استفاده مي‌كنند. امواج راديويي اغلب به عنوان يك حامل راديويي تلقي مي‌گردند، چرا كه اين امواج وظيفه انتقال انرژي الكترومغناطيسي از فرستنده را به گيرنده دورتر از خود بعهده دارند[50]. داده هنگام ارسال برروي موج حامل راديويي سوار مي‌شود و در گيرنده نيز به راحتي از موج حامل تفكيك مي‌گردد. به اين عمل مدولاسيون اطلاعات به موج حامل گفته مي‌شود. هنگاميكه داده با موج راديويي حامل مدوله مي‌شود، سيگنال راديويي داراي فركانس‌هاي مختلفي علاوه بر فركانس اصلي موج حامل مي‌گردد. به عبارت ديگر فركانس اطلاعات داده به فركانس موج حامل اضافه مي‌شود. در گيرنده راديويي براي استخراج اطلاعات، گيرنده روي فركانس خاصي تنظيم مي‌گردد و ساير فركانس‌هاي اضافي فيلتر مي‌شوند.

2-8 تصوير يك WLAN]51]

در يك ساختار WLAN، يك دستگاه فرستنده و گيرنده مركزي، Access Point(AP) خوانده مي‌شود. AP با استفاده از كابل شبكه استاندارد به شبكه محلي سيمي متصل مي‌گردد. در حالت ساده،‌ گيرنده AP وظيفه دريافت، ذخيره و ارسال داده را بين شبكه محلي سيمي و WLAN بعهده دارد. AP با آنتني كه به آن متصل است، مي‌تواند در محل مرتفع و يا هر مكاني كه امكان ارتباط بهتر را فراهم مي‌كند، نصب شود.
هر كاربر مي‌تواند از طريق يك كارت شبكه بي‌سيم (Wireless Adapter) به سيستم WLAN متصل شود. اين كارت‌ها به صورت استاندارد براي رايانه‌هاي شخصي و كيفي ساخته مي‌شوند. كارت WLAN به عنوان واسطي بين سيستم عامل شبكه كاربر و امواج دريافتي از آنتن عمل مي‌كند. سيستم عامل شبكه عملاً درگير چگونگي ارتباط ايجاد شده نخواهد بود.[52]
امروزه استاندارد غالب در شبكه‌هاي WLAN، IEEE802.11 مي‌باشد. گروهي كه بر روي اين استاندارد كار مي‌كند در سال 1990 با هدف توسعه استاندارد جهاني شبكه‌ سازي بي‌سيم با سرعت انتقال 1 تا 2 مگابيت در ثانيه شكل گرفت. استاندارد مذكور با نام IEEE802.11a شناخته مي‌شود. استاندارد IEEE802.11b كه جديدتر است، سرعت انتقال را تا 5/5 و 11مگابيت در ثانيه مي‌افزايد.[53]
WLANها از دو توپولوژي حمايت مي‌كنند:
- ad hoc topology
- infrastructure topology
در توپولوژي ad hoc كامپيوترها به شبكه بي‌سيم مجهز هستند و مستقيماً با يكديگر به شكل
Peer- to- peer ارتباط برقرار مي‌نمايند.
كامپيوترها براي ارتباط بايد در محدوده يكديگر قرار داشته باشند. اين نوع شبكه براي پشتيباني از تعداد محدودي از كامپيوترها، مثلاً در محيط خانه يا دفاتر كوچك طراحي مي‌شود.
"امروزه نوعي از توپولوژي ad hoc به نام "ad hoc peer-to-peer networking" مطرح است. اين نوع شبكه كه به شبكه "‌Mesh" نيز معروف است، شبكه‌اي پويا از دستگاههاي بي‌سيم است كه به هيچ نوع زيرساخت موجود يا كنترل مركزي وابسته نيست. در اين شرايط، دستگاههاي شبكه همچنين به مانند گرههايي عمل مي‌كنند كه كاربران از طريق آنها مي‌توانند داده‌ها را انتقال دهند، به اين معني كه دستگاه هر كاربر بعنوان مسيرياب و تكراركننده(Repeater) عمل مي‌كند. اين شبكه نوع تكامل‌يافته شبكه Point-to-multipoint است كه در آن همه كاربران مي‌بايست براي استفاده از شبكه دسترسي مستقيم به نقطه دستيابي مركزي داشته باشند. در معماري Mesh كاربران مي‌توانند بوسيله
Multi-Hopping، از طريق گرههاي ديگر به نقطه مركزي وصل شوند، بدون اينكه به ايجاد هيچگونه
پيوند مستقيم RF نياز باشد.بعلاوه در شبكه Mesh در صورتيكه كاربران بتوانند يك پيوند فركانس راديويي برقرار كنند، نيازي به نقطه دسترسي(Access Point) نيست و كاربران مي‌توانند بدون وجود يك نقطه كنترل مركزي با يكديگر، فايلها، نامه‌هاي الكترونيكي و صوت و تصوير را به اشتراك بگذارند. اين ارتباط دو نفره، به آساني براي دربرگرفتن كاربران بيشتر قابل گسترش است."[54]
توپولوژي infrastructure اصولاً براي گسترش و افزايش انعطاف‌پذيري شبكه‌هاي كابلي معمولي بكار مي‌رود. بدين شكل كه اتصال كامپيوترهاي مجهز به تكنولوژي بي‌سيم را با استفاده از Access Point به آن امكان مي‌سازد. در برخي موارد، يك AP كامپيوتري است كه كارت شبكه بي‌سيم را كنار كارت شبكه معمولي - كه آن را به يك LAN كابلي متصل مي‌كند - دارا مي‌باشد. كامپيوترهاي بي‌سيم با استفاده از AP به عنوان واسطه با شبكه كابلي ارتباط برقرار مي‌كنند. AP اساساً بعنوان يك Translation Bridge عمل مي‌كند، زيرا سيگنال‌هاي شبكه بي‌سيم را به سيگنال‌هاي شبكه كابلي تبديل مي‌كند. مانند تمام تكنولوژي‌هاي ارتباطي بي‌سيم،‌ شرايط مسافتي و محيطي مي‌توانند بر روي عملكرد ايستگاههاي سيار بسيار تأثير گذار باشند. يك AP مي‌تواند 10 تا 20 كامپيوتر را پشتيباني كند، بسته به اينكه ميزان استفاده آنها از LAN چقدر است. اين پشتيباني تا زماني ادامه دارد كه آن كامپيوترها در شعاع تقريبي 100 تا 200 فوت نسبت به AP قرار داشته باشند. موانع فيزيكي مداخله كننده اين عملكرد را به طرز چشمگيري كاهش مي‌دهند.

Cell
2-9.شبكهWLANبا يكAP((AccessPoint

در شكل فوق يك Access Point از طريق يك كابل به شبكه LAN متصل شده است. در اينجا وظيفه يك AP دريافت اطلاعات از سرويس گيرنده‌ها (Clients) از طريق هوا و ارسال آن اطلاعات از طريق يك پورت به hub مي باشد. AP به عنوان يك پل ارتباطي بين شبكه WLAN و شبكه LAN عمل مي‌كند.
ناحيه‌اي كه توسط يك AP تحت پوشش قرار مي‌گيرد سلول (Cell) ناميده مي‌شود. هر ايستگاه در داخل Cell مي‌تواند به AP دسترسي پيدا كند. وظيفه يك AP ايجاد هماهنگي بين سرويس گيرندگان (Clients) شبكه WLAN و يك شبكه LAN مي‌باشد.[55]
به منظور گسترش بخش بي‌سيم و تحت پوشش قرار دادن سرويس گيرندگان بيشتر، مي‌توان از APهاي متعدد در مناطق مختلف استفاده كرد،‌ و يا اينكه يك ٍExtension point را بكار گرفت. Extension point، يك تقويت كننده سيگنال‌هاي بي‌سيم است كه به عنوان ايستگاهي بين سرويس گيرندگان بي‌سيم و AP عمل مي‌كند. استاندارد IEEE 802.11 دو سلول را به عنوان يك BSS (Basic Service Set) در نظر مي‌گيرد. اگر شبكه از چند Access Point استفاده كند، APها با يك ستون فقرات بنام DS (Distribution System) به هم اتصال مي‌يابند. DS معمولاً يك شبكه كابلي است، اما مي‌توان آن را بي‌سيم هم در نظر گرفت.[56]
استاندارد IEEE 802.11 از سه نوع سيگنال در لايه فيزيكي پشتيباني مي‌كند:[57]
- (DSSS) Direct Sequence Spread Spectrum: يك روش انتقال راديويي است كه در آن سيگنال‌هاي خروجي با استفاده از يك كد ديجيتال مدوله مي‌شوند. در نتيجه هر بيت از ديتا به چند بيت تبديل مي‌شود و سيگنال مي‌تواند در فركانس وسيع‌تر پراكنده شود. استفاده از DSSS به همراه روش CCK (Complimentary Code Keying) باعث مي‌شود سيستم‌هاي IEEE 802.11b به سرعت11 مگابيت در ثانيه انتقال دست يابند. در جائيكه شرايط به نحوي است كه امكان تداخل،‌ نويزنپذيري يا وجود دستگاههاي كاري هم‌فركانس در منطقه موجود نباشد يا بسيار كم باشد از شيوه DSSS استفاده مي‌شود. در اين شيوه مي‌توان از تمامي عرض باند موجود در طيف گسترده شده (مثلاً 10MHZ يا بيشتر) بهره جست و لذا به شبكه‌اي با سرعت 10 مگابيت در ثانيه يا بالاتر دست يافت. اما در محيط‌هاي شلوغ به لحاظ ترافيك امواج مثلاً محيط‌هاي شهري بزرگ، بكار بردن اين تكنولوژي عليرغم وجود كدينگ‌هاي پيشرفته و تقسيم‌بندي‌هاي فركانسي، خالي از بروز تداخل‌ها و يا اشكالات احتمالي نخواهد بود.
- (FHSS) Frequency Hopping Spread Spectrum: يك روش انتقال راديويي كه در آن انتقال دهنده به طور مداوم تغييرات سريعي را در فركانس - بر طبق يك الگوريتم موجود - انجام مي‌دهد. دريافت كننده براي خواندن سيگنال‌هاي دريافتي، دقيقاً همان تغييرات را انجام مي‌دهد. در IEEE 802.11a مي‌توان از FHSS استفاده كرد اما سيستم IEEE 802.11b از اين روش حمايت نمي‌كند.
- Infrared: در ارتباطاتinfrared (مادون قرمز) از فركانسهاي بالا - دقيقا زير طيف نور مرئي- استفاده مي‌شود. در اين روش سيگنالها نمي‌توانند از اشياء و ديوارها عبور كنند. اين امر بكارگيري
تكنولوژي مادون قرمز را محدود مي‌سازد. در فناوري مادون قرمز ارسال كننده و دريافت كننده بايد يكديگر را ببينند(در خط ديد يكديگر باشند) همانند يك كنترل كننده راه دور دستگاه تلويزيون. بطور كلي در ارتباطات داخل ساختمان كه فاصله ايستگاهها كم باشد از اين روش استفاده مي‌شود. در اينجا بجاي سيم يا فيبر نوري كه رسانه‌هاي انتقال هستند، از امواج راديويي يا نور مادون قرمز بعنوان رسانه انتقال استفاده مي‌شود. امواج راديويي بخاطر برد، پهناي باند و پوشش مكاني بيشتر، از نور مادون قرمز كاربرد بيشتري دارند.
در اين قسمت به برخي مزاياي يك WLAN نسبت به يك شبكه كابلي مي‌پردازيم. از WLANها مي‌توان در مكانهايي كه امكان كابل‌كشي وجود ندارد استفاده كرد و بدون نياز به كابل‌كشي آنها را گسترش داد. استفاده كننده WLAN مي‌تواند كامپيوتر خود را بدون قطع كابل، به هر نقطه از سازمان منتقل كند. با وجود اينكه سخت‌افزار مورد نياز براي WLAN گرانتر از تجهيزات شبكه سيمي است، ولي بهره‌وري و انعطاف‌پذيري آن باعث مي‌شود كه در طول زمان قيمت تمام شده كمتر شود، بخصوص در محيطهايي كه شبكه مورد نظر پيوسته در حال انتقال و تغيير مداوم است.
سيستمهاي WLAN مي‌توانند با فناوريهاي مختلف شبكه تركيب شوند و شبكه‌هايي با كاربردها و امكانات خاص را به نحو مطلوبي ايجاد كنند. پيكر‌بندي اين شبكه‌ها براحتي قابل تغيير است و اين شبكه‌ها مي‌توانند از حالت نقطه به نقطه تا شبكه‌هايي با زيرساختار پيچيده با صدها كاربر متحرك گسترش يابند.
در شبكه‌هاي بي‌سيم مديران شبكه مي‌توانند جابجايي، گسترش و اصلاح شبكه را آسانتر انجام دهند و با استفاده از اين سيستم به نصب كامپيوترهاي شبكه در ساختمانهاي قديمي و يا مكانهايي كه امكان كابل‌كشي در آنها وجود ندارد و نيز مكانهايي كه فاصله آنها از يكديگر زياد است بپردازند و بدين شكل امكان دسترسي سريع به اطلاعات را فراهم كنند.

پارامترهاي مؤثر در انتخاب و پياده‌سازي يك سيستم WLAN
1- برد محدوده پوشش: اثر متقابل اشياء موجود در ساختمان(نظير ديوارها، فلزات و افراد) مي‌تواند بر روي انرژي انتشار اثر بگذارد و در نتيجه برد و محدوده پوشش سيستم را تحت تأثير قرار دهد. براي سيگنالهاي مادون قرمز، اشياي موجود در ساختمان مانعي ديگر بشمار مي‌رود و در نتيجه محدوديتهاي خاصي را در شبكه بوجود مي‌آورد. بيشتر سيستمهاي WLAN از امواج راديويي RF استفاده مي‌كنند، زيرا مي‌تواند از ديوارها و موانع عبور كند. برد(شعاع پوشش) براي سيستمهاي WLAN بين 10 تا 30 متر متغير است.
2- سرعت انتقال داده: همانند شبكه‌هاي كابلي، سرعت انتقال داده واقعي در شبكه‌هاي بي‌سيم، به نوع محصولات و توپولوژي شبكه بستگي دارد. تعداد كاربران، فاكتورهاي انتشار مانند برد، مسيرهاي ارتباطي، نوع سيستم WLAN استفاده شده، نقاط كور و گلوگاههاي شبكه، از پارامترهاي مهم و تأثيرگذار در سرعت انتقال داده بحساب مي‌آيند. بعنوان يك مقايسه با مودمهاي امروزي(با سرعت 56 كيلو بيت در ثانيه) سرعت عملكرد WLANها در حدود 30 برابر سريعتر از اين مودمهاست.
3- سازگاري با شبكه‌هاي موجود: بيشتر سيستمهاي WLAN با استانداردهاي صنعتي متداول شبكه‌هاي كابلي نظير Ethernet و Token Ring سازگار است. با نصب درايورهاي مناسب در ايستگاههاي WLAN، سيستمهاي عامل آن ايستگاهها دقيقا مانند ساير ايستگاههاي موجود در شبكه LAN كابلي بكار گرفته مي‌شود.
سازگاري با ديگر محصولات WLAN: به سه دليل مشتريان هنگام خريد محصولات WLAN بايد مراقب باشند كه سيستم موردنظر بتواند با ساير محصولات WLAN توليدكنندگان ديگر سازگاري داشته باشد:
- ممكن است هر محصول از تكنولوژي خاصي استفاده كرده باشد، براي مثال سيستمي كه از فناوري FHSS استفاده كند نمي‌تواند با سيستمي با فناوري DSSS كار كند.
- اگر فركانس كار دو سيستم با يكديگر يكسان نباشد،‌حتي در صورت استفاده از فناوري مشابه، امكان كاركردن با يكديگر فراهم نخواهد شد.
- حتي توليدكنندگان مختلف اگر از يك فناوري و يك فركانس استفاده كنند، بدليل روشهاي مختلف طراحي ممكن است با ساير محصولات ديگر سازگاري نداشته باشد.
5- تداخل و اثرات متقابل: طبيعت امواج راديويي در سيستمهاي WLAN ايجاب مي‌كند تا سيستمهاي مختلف كه داراي طيفهاي فركانسي يكساني هستند، بر روي يكديگر اثر تداخل داشته باشند. با اين وجود اغلب توليدكنندگان در توليد محصولات خود تمهيداتي را براي مقابله با آن بكار مي‌گيرند، به نحوي كه وجود چند سيستم WLAN نزديك به يكديگر، تداخلي در ديگر سيستمها بوجود نمي‌آورد.
6- ملاحظات مجوز فركانسي: در اغلب كشورها ارگانهاي ناظر بر تخصيص فركانس راديويي، محدوده فركانس شبكه‌هاي WLAN را مشخص كرده‌اند. اين محدوده ممكن است در همه كشورها يكسان نباشد. معمولا سازندگان تجهيزات WLAN فركانس سيستم را در محدوده مجاز قرار مي‌دهند. در نتيجه كاربر نياز به اخذ مجوز فركانسي ندارد. اين محدوده فركانس به ISM معروف است. محدوده بين‌المللي اين فركانسها 928-902 مگاهرتز،483/2-4/2 گيگاهرتز، 535-15/5 گيگاهرتز و 875/5-725/5 گيگاهرتز است. بنابراين توليدكنندگان تجهيزات WLAN بايد اين محدوده مجوز فركانسي را در سيستمهاي خود رعايت كنند.
7- سادگي و سهولت استفاده: اغلب كاربران در مورد مزيتهاي WLANها اطلاعات كمي دارند. مي‌دانيم كه سيستم عامل اصولاً به نحوه اتصال سيمي و يا بي‌سيم شبكه وابستگي ندارند. بنابراين برنامه‌هاي كاربردي بر روي شبكه بطور يكسان عمل مي‌نمايند. توليدكنندگان WLAN ابزار مفيدي را براي سنجش وضعيت سيستم و تنظيمات مورد در اختيار كاربران قرار مي‌دهند. مديران شبكه به سادگي مي‌توانند نصب و راه‌اندازي سيستم را با توجه به توپولوژي شبكه موردنظر انجام دهند. در WLAN كليه كاربران بدون نياز به كابل‌كشي مي‌توانند با يكديگر ارتباط برقرار كنند. عدم نياز به كابل‌كشي موجب مي‌شود كه تغييرات، جابجايي و اضافه كردن در شبكه به آساني انجام شود. در نهايت به موجب قابليت جابجايي آسان تجهيزات WLANمدير شبكه مي‌تواند قبل از اينكه تجهيزات شبكه را در مكان اصلي خود نصب كند، ابتدا آنها را راه‌اندازي كند و تمامي مشكلات احتمالي شبكه را برطرف سازد و پس از تاييد نهايي در محل اصلي جايگذاري نمايد و پس از پيكر‌بندي، هرگونه جابجايي از يك نقطه به نقطه ديگر را بدون كمترين تغييرات اصلاح نمايد.
8- امنيت: از آنجايي كه سرمنشأ فناوري بي‌سيم در كاربردهاي نظامي بوده است، امنيت از جمله مقولات مهم در طراحي سيستمهاي بي‌سيم بشمار مي‌رود. بحث امنيت هم در ساختار تجهيزات WLAN به نحو مطلوبي پيش‌بيني شده است و اين امر شبكه‌هاي بي‌سيم را بسيار امن‌تر از شبكه‌هاي سيمي كرده است. براي گيرنده‌هايي كه دستيابي مجاز به سيگنالهاي دريافتي ندارند، دسترسي به اطلاعات موجود در WLAN بسيار مشكل است. به دليل تكنيكهاي پيشرفته رمزنگاري براي اغلب گيرنده‌هاي غيرمجاز دسترسي به ترافيك شبكه غيرممكن است. عموما گيرنده‌هاي مجاز بايد قبل از ورود به شبكه و دسترسي به اطلاعات آن، از نظر امنيتي مجوز لازم را دارا باشند.
9- هزينه: براي پياده‌سازي يك WLAN هزينه اصلي شامل دو بخش است: هزينه‌هاي زيرساختار شبكه مانند APهاي شبكه و نيز هزينه كارتهاي شبكه جهت دسترسي كاربران به WLAN.
هزينه‌هاي زيرساختار شبكه به تعداد APهاي موردنياز شبكه بستگي دارد. قيمت يك AP بين 1000 تا2000 دلار مي‌باشد. تعداد APهاي شبكه به شعاع عملكرد شبكه، تعداد كاربران و نوع سرويسهاي موجود در شبكه بستگي دارد و هزينه كارتهاي شبكه با توجه به يك شبكه رايانه‌اي استاندارد حدود 300 تا 500 دلار براي هر كاربر مي‌باشد. هزينه نصب و راه‌اندازي يك شبكه بي‌سيم به دو دليل كمتر از نصب و راه‌اندازي يك شبكه سيمي مي‌باشد:
- هزينه كابل‌كشي و پيدا كردن مسير مناسب بين كاربران و ساير هزينه‌هاي مربوط به نصب تجهيزات در ساختمان، بخصوص در فواصل طولاني كه استفاده از فيبر نوري يا ساير خطوط گرانقيمت ضروري است، بسيار زياد است.
- به دليل قابليت جابجايي، اضافه كردن و تغييرات ساده در WLAN، هزينه‌هاي سربار، براي اين تغييرات و تعمير و نگهداري آن بسيار كمتر از شبكه سيمي است.
10- قابليت گسترش سيستم: با يك شبكه بي‌سيم مي‌توان شبكه‌اي با توپولوژي بسيار ساده تا بسيار پيچيده را طراحي كرد. در شبكه‌هاي بي‌سيم با افزايش تعداد APها يا WBها مي‌توان محدوده فيزيكي تحت پوشش و تعداد كاربران موجود در شبكه را تا حد بسيار زيادي گسترش داد. شعاع عملكرد اين شبكه تا حدود 20 كيلومتر مي‌باشد.
11- اثرات جانبي: توان خروجي يك سيستم بي‌سيم بسيار پايين است. از آنجايي كه امواج راديويي با افزايش فاصله به سرعت مستهلك مي‌گردند و در عين حال، افرادي را كه در محدوده تشعشع انرژي RF هستند، تحت تاثير قرار مي‌دهند، بايد ملاحظات حفظ سلامت با توجه به مقررات دولتي رعايت گردد. با اين وجود اثرات مخرب اين سيستمها زياد نمي‌باشد.


Abee Chm eBook Creator
This page is displayed here instead of the page you expect because this eBook is created with the unregistered version of Abee Chm eBook Creator. You should buy the program to avoid this situation.